Back to overview
Resolved

Excel Add-in - Distribution Issue

Sep 24, 2026 at 5:16pm UTC
Affected services
Cloud (United States)
Cloud (Canada)
Cloud (Europe)
Training Site

Resolved
Sep 24, 2026 at 7:35pm UTC

The fix has been applied and the issue is now resolved. The service is operating normally. Thank you for your patience.

Updated
Sep 24, 2026 at 6:48pm UTC

We have identified the root cause of the issue. Our team is actively working to implement a fix, and we will share an update as soon as it's available. Thank you for your patience and understanding.

Created
Sep 24, 2026 at 5:16pm UTC

We're aware of an issue affecting the Excel add-in distribution and are actively investigating. Other services remain unaffected. We'll post an update as soon as we know more.