Back to overview
Downtime

Download platform - Outage

Mar 13, 2023 at 2:41pm UTC
Affected services
Download Site

Resolved
Mar 13, 2023 at 3:52pm UTC

This incident has been resolved.

Updated
Mar 13, 2023 at 2:46pm UTC

A fix has been implemented and we are monitoring the results.

Created
Mar 13, 2023 at 2:41pm UTC

There is currently an outage with our Download site. We are investigating the issue.