Back to overview

Helpdesk Outage

Jun 06 at 11:50am EDT
Affected services
Helpdesk

Resolved
Jun 06 at 02:32pm EDT

The issue has been resolved and the Helpdesk is available again.

Updated
Jun 06 at 12:15pm EDT

We have identified the issue and are working towards resolving it.

Created
Jun 06 at 11:50am EDT

The helpdesk is currently unavailable due to an outage. We are investigating the issue.