Cloud services - North America - Outage
Resolved
Jul 18 at 11:24pm EDT
The issues with cloud services have been resolved.
Affected services
Helpdesk
Cloud (North America)
License Portal
Updated
Jul 18 at 10:26pm EDT
Services are coming back online. We are confirming that all services are functional. We will continue to monitor the situation.
Affected services
Helpdesk
Cloud (North America)
License Portal
Updated
Jul 18 at 07:13pm EDT
We have identified an issue affecting the customers. We are currently investigating it.
Affected services
Helpdesk
Cloud (North America)
License Portal
Created
Jul 18 at 06:29pm EDT
The cloud services in North America are currently unavailable. We are investigating the issue.
Affected services
Helpdesk
Cloud (North America)
License Portal