Back to overview
Downtime

Cloud service - Major Outage

May 13 at 04:47pm EDT
Affected services
Cloud (North America)
Cloud (Europe)
License Portal
Helpdesk

Resolved
May 13 at 08:57pm EDT

The incident is now resolved. The service is currently performing as expected.

Updated
May 13 at 07:33pm EDT

The services are coming back online. We are monitoring the situation.

Updated
May 13 at 05:54pm EDT

We have Identified the issue. We are currently applying a fix.

Created
May 13 at 04:47pm EDT

The services are currently unavailable. We are investigating the outage.