Back to overview
Degraded
Excel Add-in - Login and data loading issue
Jul 27, 2026 at 12:06pm UTC
Affected services
Cloud (United States)
Cloud (Canada)
Cloud (Europe)
Updated
Jul 27, 2026 at 4:40pm UTC
We've identified the cause. Exports above certain sizes are failing. Excel exports greater than 10,000 rows, and workbook exports greater than 50,000 rows will fail. We are working on a fix. Thank you for your patience.
Affected services
Created
Jul 27, 2026 at 12:06pm UTC
We're aware of an issue affecting the Excel add-in and are actively investigating. Other services remain unaffected. We'll post an update as soon as we know more.
Affected services